$re = '/(\S+)(?:)*.CITIBANK/m';
$str = 'Also see attached letter for and CITIBANK
Also see attached letter for ad CITIBANK
Also see attached letter for an CITIBANK
Also see attached letter for nd CITIBANK';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);