re = /(\S+)(?:)*.CITIBANK/m
str = 'Also see attached letter for and CITIBANK
Also see attached letter for ad CITIBANK
Also see attached letter for an CITIBANK
Also see attached letter for nd CITIBANK'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end