#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(January|February|March|April|May|June|July|August|September|October|November|December) (3[01]|[12][0-9]|0[1-9]) (19|20)\d{2}$"
Local $sString = "Should pass:" & @CRLF & _
"" & @CRLF & _
"January 12 1975" & @CRLF & _
"February 31 2000" & @CRLF & _
"May 01 2099" & @CRLF & _
"" & @CRLF & _
"Should fail:" & @CRLF & _
"" & @CRLF & _
"Abbreviated month:" & @CRLF & _
"Jan 12 1975" & @CRLF & _
"" & @CRLF & _
"Day out of range:" & @CRLF & _
"February 32 2000" & @CRLF & _
"" & @CRLF & _
"No leading zero on day:" & @CRLF & _
"May 1 2099" & @CRLF & _
"" & @CRLF & _
"Year out of range:" & @CRLF & _
"March 11 1234" & @CRLF & _
"" & @CRLF & _
"Year too long:" & @CRLF & _
"May 01 20000" & @CRLF & _
"" & @CRLF & _
"Year too short:" & @CRLF & _
"May 01 19" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")