package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(January|February|March|April|May|June|July|August|September|October|November|December) (3[01]|[12][0-9]|0[1-9]) (19|20)\d{2}$`)
var str = `Should pass:
January 12 1975
February 31 2000
May 01 2099
Should fail:
Abbreviated month:
Jan 12 1975
Day out of range:
February 32 2000
No leading zero on day:
May 1 2099
Year out of range:
March 11 1234
Year too long:
May 01 20000
Year too short:
May 01 19
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}