import Foundation
let pattern = #"^(January|February|March|April|May|June|July|August|September|October|November|December) (3[01]|[12][0-9]|0[1-9]) (19|20)\d{2}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Should pass:
January 12 1975
February 31 2000
May 01 2099
Should fail:
Abbreviated month:
Jan 12 1975
Day out of range:
February 32 2000
No leading zero on day:
May 1 2099
Year out of range:
March 11 1234
Year too long:
May 01 20000
Year too short:
May 01 19
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)