use strict;
my $str = 'Should pass:
January 12 1975
February 31 2000
May 01 2099
Should fail:
Abbreviated month:
Jan 12 1975
Day out of range:
February 32 2000
No leading zero on day:
May 1 2099
Year out of range:
March 11 1234
Year too long:
May 01 20000
Year too short:
May 01 19
';
my $regex = qr/^(January|February|March|April|May|June|July|August|September|October|November|December) (3[01]|[12][0-9]|0[1-9]) (19|20)\d{2}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}