using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"241(?!50)(?!9)\d{9}L\d{3}";
string input = @"241200241511L002
241500241511L002
241900241511L002";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}