$re = '/241(?!50)(?!9)\d{9}L\d{3}/m';
$str = '241200241511L002
241500241511L002
241900241511L002';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);