const regex = /241(?!50)(?!9)\d{9}L\d{3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('241(?!50)(?!9)\\d{9}L\\d{3}', 'gm')
const str = `241200241511L002
241500241511L002
241900241511L002`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}