package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((\\)(?:\w*[rR]ef\*?))(\{.*?\})`)
var str = `\ref{label}
ref{}
\ref
\Ref{}
text \ref{text} text
\ref{text} text }
\ref*{}
\ref{{{{{{}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}