import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\\\)(?:\\w*[rR]ef\\*?))(\\{.*?\\})";
final String string = "\\ref{label}\n"
+ "ref{}\n"
+ "\\ref\n"
+ "\\Ref{}\n"
+ "text \\ref{text} text\n"
+ "\\ref{text} text }\n"
+ "\\ref*{}\n"
+ "\\ref{{{{{{}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}