#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b\d+\b"
Local $sString = "python3 " & @CRLF & _
"foo 3" & @CRLF & _
"bar4 5 6 8" & @CRLF & _
"This is python3 and learning it takes 100 hours"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)