$re = '/\b\d+\b/m';
$str = 'python3
foo 3
bar4 5 6 8
This is python3 and learning it takes 100 hours';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;