#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:foo|bar)(?: (?:foo|bar))*$"
Local $sString = "Valid instances are: " & @CRLF & _
"foo" & @CRLF & _
"bar" & @CRLF & _
"foo foo" & @CRLF & _
"foo bar" & @CRLF & _
"foo foo bar" & @CRLF & _
"foo bar foo bar" & @CRLF & _
"" & @CRLF & _
"Invalid instances: " & @CRLF & _
"foofoo bar" & @CRLF & _
"baz foo bar" & @CRLF & _
"foo bar baz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")