re = /^(?:foo|bar)(?: (?:foo|bar))*$/m
str = 'Valid instances are:
foo
bar
foo foo
foo bar
foo foo bar
foo bar foo bar
Invalid instances:
foofoo bar
baz foo bar
foo bar baz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end