// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:foo|bar)(?: (?:foo|bar))*$").unwrap();
let string = "Valid instances are:
foo
bar
foo foo
foo bar
foo foo bar
foo bar foo bar
Invalid instances:
foofoo bar
baz foo bar
foo bar baz";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}