import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:foo|bar)(?: (?:foo|bar))*$";
final String string = "Valid instances are: \n"
+ "foo\n"
+ "bar\n"
+ "foo foo\n"
+ "foo bar\n"
+ "foo foo bar\n"
+ "foo bar foo bar\n\n"
+ "Invalid instances: \n"
+ "foofoo bar\n"
+ "baz foo bar\n"
+ "foo bar baz";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}