const regex = /<[/]?(wd:response)[\s+]?>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<[\/]?(wd:response)[\\s+]?>', 'gm')
const str = `<wd:response><wd:response-data></wd:response-data></wd:response >`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}