$re = '/<[/]?(wd:response)[\s+]?>/m';
$str = '<wd:response><wd:response-data></wd:response-data></wd:response >';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);