re = /<[\/]?(wd:response)[\s+]?>/m
str = '<wd:response><wd:response-data></wd:response-data></wd:response >'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end