package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\s\x{0020}\x{00A0}\x{1680}\x{2000}-\x{200b}\x{202F}\x{205F}\x{3000}]+`)
var str = `Почему регулярка не видит пробел? Потому что это был особый пробел.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}