const regex = /[\s\x{0020}\x{00A0}\x{1680}\x{2000}-\x{200b}\x{202F}\x{205F}\x{3000}]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\s\\x{0020}\\x{00A0}\\x{1680}\\x{2000}-\\x{200b}\\x{202F}\\x{205F}\\x{3000}]+', 'gm')
const str = `Почему регулярка не видит пробел? Потому что это был особый пробел.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}