re = /[\s\x{0020}\x{00A0}\x{1680}\x{2000}-\x{200b}\x{202F}\x{205F}\x{3000}]+/m
str = 'Почему регулярка не видит пробел? Потому что это был особый пробел.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end