$re = '/[\s\x{0020}\x{00A0}\x{1680}\x{2000}-\x{200b}\x{202F}\x{205F}\x{3000}]+/m';
$str = 'Почему регулярка не видит пробел? Потому что это был особый пробел.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);