using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\bSTART)\b(?:(?!\bSTART\b).)*\b(?=END\b)";
string input = @"""END START START bad result START good result 1 END START good result 2 END START START""
STARTED foo END
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}