use strict;
my $str = '"END START START bad result START good result 1 END START good result 2 END START START"
STARTED foo END
';
my $regex = qr/(?<=\bSTART)\b(?:(?!\bSTART\b).)*\b(?=END\b)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}