re = /(?<=\bSTART)\b(?:(?!\bSTART\b).)*\b(?=END\b)/m
str = '"END START START bad result START good result 1 END START good result 2 END START START"
STARTED foo END
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end