package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[^;]*;){3}([^;]*);`)
var str = `00.000000 00.000000; X-XX000-0000-0; France; Paris; Street 12a;`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}