import re
regex = re.compile(r"(?:[^;]*;){3}([^;]*);")
test_str = "00.000000 00.000000; X-XX000-0000-0; France; Paris; Street 12a;"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")