import Foundation
let pattern = #"(?:[^;]*;){3}([^;]*);"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"00.000000 00.000000; X-XX000-0000-0; France; Paris; Street 12a;"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}