import Foundation
let pattern = #"^\s*((((([0-9A-Fa-f]{1,4})|\*):){7}((([0-9A-Fa-f]{1,4})|\*)|:))|(((([0-9A-Fa-f]{1,4})|\*):){6}(:(([0-9A-Fa-f]{1,4})|\*)|((25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)(\.(25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)){3})|:))|(((([0-9A-Fa-f]{1,4})|\*):){5}(((:(([0-9A-Fa-f]{1,4})|\*)){1,2})|:((25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)(\.(25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)){3})|:))|(((([0-9A-Fa-f]{1,4})|\*):){4}(((:(([0-9A-Fa-f]{1,4})|\*)){1,3})|((:(([0-9A-Fa-f]{1,4})|\*))?:((25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)(\.(25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)){3}))|:))|(((([0-9A-Fa-f]{1,4})|\*):){3}(((:(([0-9A-Fa-f]{1,4})|\*)){1,4})|((:(([0-9A-Fa-f]{1,4})|\*)){0,2}:((25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)(\.(25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)){3}))|:))|(((([0-9A-Fa-f]{1,4})|\*):){2}(((:(([0-9A-Fa-f]{1,4})|\*)){1,5})|((:(([0-9A-Fa-f]{1,4})|\*)){0,3}:((25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)(\.(25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)){3}))|:))|(((([0-9A-Fa-f]{1,4})|\*):){1}(((:(([0-9A-Fa-f]{1,4})|\*)){1,6})|((:(([0-9A-Fa-f]{1,4})|\*)){0,4}:((25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)(\.(25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)){3}))|:))|(:(((:(([0-9A-Fa-f]{1,4})|\*)){1,7})|((:(([0-9A-Fa-f]{1,4})|\*)){0,5}:((25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)(\.(25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)){3}))|:)))\s*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2404:6800:4003:c02::8a
2404:6800:4003:804::200e
2001:4998:c:a06::2:4008
fe80::21d8:f50:c295:c4be
2001:cdba::e:9652
2001:cdba:0:0:0:0:3257:9652
2001:cdba::3257:9652
2001:cdba::1222
21DA:D3:0:2F3B:2AA:FF:FE28:9C5A
2001:cdba::1:2:3:3257:9652
2404::4003:804::200e
1234:Fd2:2:1:89::4500
1234:Fd2:12:1:89::4500
2001:DB8:0:0:0:0:0:*
2001:DB8:0:0:0:*:*:*
2001:DB8::0:*
2001:DB8:0:0:0:*:0:1
::
2001:DB8:0:0:0:*
2001:*:1
*
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)