package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<comment>(?:\w+\s)+(?:(?<ip>\d{1,255}.\d{1,255}.\d{1,255}.\d{1,255}))\s(?:\w+\s)\d{1,65535}.*)`)
var str = `Mar 6 17:15:20 Zant sshd[29880] <Error>: error: maximum authentication attempts exceeded for invalid user admin from 190.232.81.120 port 41095 ssh2 [preauth]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}