$re = '/(?<comment>(?:\w+\s)+(?:(?<ip>\d{1,255}.\d{1,255}.\d{1,255}.\d{1,255}))\s(?:\w+\s)\d{1,65535}.*)/mx';
$str = 'Mar 6 17:15:20 Zant sshd[29880] <Error>: error: maximum authentication attempts exceeded for invalid user admin from 190.232.81.120 port 41095 ssh2 [preauth]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);