use strict;
my $str = 'Mar 6 17:15:20 Zant sshd[29880] <Error>: error: maximum authentication attempts exceeded for invalid user admin from 190.232.81.120 port 41095 ssh2 [preauth]';
my $regex = qr/(?<comment>(?:\w+\s)+(?:(?<ip>\d{1,255}.\d{1,255}.\d{1,255}.\d{1,255}))\s(?:\w+\s)\d{1,65535}.*)/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}