import re
regex = re.compile(r"""
(?<comment>(?:\w+\s)+(?:(?<ip>\d{1,255}.\d{1,255}.\d{1,255}.\d{1,255}))\s(?:\w+\s)\d{1,65535}.*)
""", flags=re.MULTILINE | re.VERBOSE)
test_str = "Mar 6 17:15:20 Zant sshd[29880] <Error>: error: maximum authentication attempts exceeded for invalid user admin from 190.232.81.120 port 41095 ssh2 [preauth]"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")