package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<your_field>\w-\w\w-\w\w\w-\d\d-\w\w\w#\w\w\w\w)`)
var str = `fields ............................................. Location=Location#All Locations#Site#City#E-MY-SIT-00-XYZ#TEST, fields..........................`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}