const regex = /(?<your_field>\w-\w\w-\w\w\w-\d\d-\w\w\w#\w\w\w\w)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<your_field>\\w-\\w\\w-\\w\\w\\w-\\d\\d-\\w\\w\\w#\\w\\w\\w\\w)', 'gm')
const str = `fields ............................................. Location=Location#All Locations#Site#City#E-MY-SIT-00-XYZ#TEST, fields..........................`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}