re = /(?<your_field>\w-\w\w-\w\w\w-\d\d-\w\w\w#\w\w\w\w)/m
str = 'fields ............................................. Location=Location#All Locations#Site#City#E-MY-SIT-00-XYZ#TEST, fields..........................'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end