package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<name>\D+)_(?<id>\d+)(_(?<color>[^\d_]{2,}))?(_(?<sub_id>\d+))?(_(?<texture_type>[DMNE]))?`)
var str = `Suit_490_red_01_E`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}