const regex = /^(?<name>\D+)_(?<id>\d+)(_(?<color>[^\d_]{2,}))?(_(?<sub_id>\d+))?(_(?<texture_type>[DMNE]))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<name>\\D+)_(?<id>\\d+)(_(?<color>[^\\d_]{2,}))?(_(?<sub_id>\\d+))?(_(?<texture_type>[DMNE]))?', 'gm')
const str = `Suit_490_red_01_E`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}