import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<name>\\D+)_(?<id>\\d+)(_(?<color>[^\\d_]{2,}))?(_(?<sub_id>\\d+))?(_(?<texture_type>[DMNE]))?";
final String string = "Suit_490_red_01_E";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}