// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<name>\D+)_(?<id>\d+)(_(?<color>[^\d_]{2,}))?(_(?<sub_id>\d+))?(_(?<texture_type>[DMNE]))?").unwrap();
let string = "Suit_490_red_01_E";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}