#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(lz|dz|sz)\.[a-z]+\.([a-z]+\.)?([a-z0-9]|-)+(\.v[1-9])?$"
Local $sString = "lz.parsys.bubu.v1" & @CRLF & _
"lz.parsys.tbps-partner-akt" & @CRLF & _
"lz.parsys.tbps-partner-akt.v1" & @CRLF & _
"dz.parsys.partner" & @CRLF & _
"dz.parsys.partner911" & @CRLF & _
"sz.edwh.partner-created" & @CRLF & _
"lz.parsys.cdckafka.tbps-partner" & @CRLF & _
"lz.parsys.tbps-partner-akt.1" & @CRLF & _
"lz.parsys.tbps-partner-akt.v1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")