// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(lz|dz|sz)\.[a-z]+\.([a-z]+\.)?([a-z0-9]|-)+(\.v[1-9])?$").unwrap();
let string = "lz.parsys.bubu.v1
lz.parsys.tbps-partner-akt
lz.parsys.tbps-partner-akt.v1
dz.parsys.partner
dz.parsys.partner911
sz.edwh.partner-created
lz.parsys.cdckafka.tbps-partner
lz.parsys.tbps-partner-akt.1
lz.parsys.tbps-partner-akt.v1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}