import re
regex = re.compile(r"^(lz|dz|sz)\.[a-z]+\.([a-z]+\.)?([a-z0-9]|-)+(\.v[1-9])?$", flags=re.MULTILINE)
test_str = ("lz.parsys.bubu.v1\n"
"lz.parsys.tbps-partner-akt\n"
"lz.parsys.tbps-partner-akt.v1\n"
"dz.parsys.partner\n"
"dz.parsys.partner911\n"
"sz.edwh.partner-created\n"
"lz.parsys.cdckafka.tbps-partner\n"
"lz.parsys.tbps-partner-akt.1\n"
"lz.parsys.tbps-partner-akt.v1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")