import Foundation
let pattern = #"^(lz|dz|sz)\.[a-z]+\.([a-z]+\.)?([a-z0-9]|-)+(\.v[1-9])?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
lz.parsys.bubu.v1
lz.parsys.tbps-partner-akt
lz.parsys.tbps-partner-akt.v1
dz.parsys.partner
dz.parsys.partner911
sz.edwh.partner-created
lz.parsys.cdckafka.tbps-partner
lz.parsys.tbps-partner-akt.1
lz.parsys.tbps-partner-akt.v1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)