#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "vid=(\d+)"
Local $sString = "http://gorid.com/api.jsp?acs=123&vid=432&skey=asdasd-asdas-adsasd&gvid=12asasass"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")