$re = '/vid=(\d+)/';
$str = 'http://gorid.com/api.jsp?acs=123&vid=432&skey=asdasd-asdas-adsasd&gvid=12asasass';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);