re = /vid=(\d+)/
str = 'http://gorid.com/api.jsp?acs=123&vid=432&skey=asdasd-asdas-adsasd&gvid=12asasass'
# Print the match result
str.match(re) do |match|
puts match.to_s
end