const regex = /vid=(\d+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('vid=(\\d+)', '')
const str = `http://gorid.com/api.jsp?acs=123&vid=432&skey=asdasd-asdas-adsasd&gvid=12asasass`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}